Vulnerability · Published Nov 18, 2025 · Assigned by GitHub_M
CVE-2025-64325Emby Server is Vulnerable to Remote Code Execution Through XSS in Admin Dashboard
High 8.4
In plain English
A high-severity cross-site scripting in Emby.Security from EmbySupport. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities).
Official description
Emby Server is a personal media server. Prior to version 4.8.1.0 and prior to Beta version 4.9.0.0-beta, a malicious user can send an authentication request with a manipulated X-Emby-Client value, which gets added to the devices section of the admin dashboard without sanitization. This issue has been patched in version 4.8.1.0 and Beta version 4.9.0.0-beta.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| EmbySupport | Emby.Security | Emby Server (Web App) < 4.8.1.0Emby Server Beta (Web App) < 4.9.0.0-beta |
Weakness: CWE-79, CWE-116 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N