Vulnerability · Published Nov 7, 2025 · Assigned by GitHub_M
CVE-2025-64187OctoPrint is vulnerable to XSS through Action Command Notifications and Prompts
Medium 4.6
In plain English
A medium-severity security flaw in OctoPrint from OctoPrint. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OctoPrint provides a web interface for controlling consumer 3D printers. Versions 1.11.3 and below are affected by a vulnerability that allows injection of arbitrary HTML and JavaScript into Action Command notifications and prompts popups generated by the printer. An attacker who successfully convinces a victim to print a specially crafted file could exploit this issue to disrupt ongoing prints, extract information (including sensitive configuration settings, if the targeted user has the necessary permissions for that), or perform other actions on behalf of the targeted user within the OctoPrint instance. This issue is fixed in version 1.11.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | octoprint | 1.11.4 | GHSA-crvm-xjhm-9h29 |
| PyPI | octoprint | 1.11.4 | PYSEC-2026-1714 |
Affected products (as reported)
Weakness: CWE-80 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N