Vulnerability · Published Feb 6, 2026 · Assigned by GitHub_M

CVE-2025-64175Gogs Vulnerable to 2FA Bypass via Recovery Code

High 7.7

In plain English

A high-severity improper authentication in gogs from gogs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.7High
Exploit odds (30 days)0.5%top 59.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, Gogs’ 2FA recovery code validation does not scope codes by user, enabling cross-account bypass. If an attacker knows a victim’s username and password, they can use any unused recovery code (e.g., from their own account) to bypass the victim’s 2FA. This enables full account takeover and renders 2FA ineffective in all environments where it's enabled.. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogogs.io/gogs0.13.4GHSA-p6x6-9mx6-26wj
Gogogs.io/gogsno fix listedGO-2026-4449

Affected products (as reported)

VendorProductVersions
gogs gogs < 0.14.0+dev< 0.13.4

Weakness: CWE-287 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References