Vulnerability · Published Nov 6, 2025 · Assigned by GitHub_M
CVE-2025-64174OpenMage is vulnerable to XSS in Admin Notifications
Medium 4.6
In plain English
A medium-severity cross-site scripting in magento-lts from OpenMage. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Magento-lts is a long-term support alternative to Magento Community Edition (CE). Versions 20.15.0 and below are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin with direct database access or the admin notification feed source to inject malicious scripts into vulnerable fields. Unescaped translation strings and URLs are printed into contexts inside app/code/core/Mage/Adminhtml/Block/Notification/Grid/Renderer/Actions.php. A malicious translation or polluted data can inject script. This issue is fixed in version 20.16.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | openmage/magento-lts | 20.16.0 | GHSA-qv78-c8hc-438r |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenMage | magento-lts | < 20.16.0 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N