Vulnerability · Published Oct 28, 2025 · Assigned by GitHub_M
CVE-2025-62800FastMCP vulnerable to reflected XSS in client's callback page
Medium 5.3
In plain English
A medium-severity cross-site scripting in fastmcp from jlowin. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values are inserted into the generated HTML, allowing arbitrary JavaScript execution in the callback server origin. The issue is fixed in version 2.13.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | fastmcp | 2.13.0 | GHSA-mxxr-jv3v-6pgc |
| PyPI | fastmcp | 2.13.0 | PYSEC-2026-1364 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
References
- https://github.com/jlowin/fastmcp/security/advisories/GHSA-mxxr-jv3v-6pgc x_refsource_CONFIRM