Vulnerability · Published Oct 28, 2025 · Assigned by GitHub_M

CVE-2025-62798Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax

Medium 5.4

In plain English

A medium-severity cross-site scripting in sharp from code16. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.2%top 87.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Sharp is a content management framework built for Laravel as a package. Prior to 9.11.1, a Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in {{ & }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. The issue has been fixed in v9.11.1 .

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistcode16/sharp9.11.1GHSA-9f58-4465-23c7

Affected products (as reported)

VendorProductVersions
code16 sharp < 9.11.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References