Vulnerability · Published Oct 30, 2025 · Assigned by GitHub_M
CVE-2025-62795JumpServer Unauthorized LDAP Configuration Access via WebSocket
High 7.1
In plain English
A high-severity incorrect authorization in jumpserver from jumpserver. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities).
Official description
JumpServer is an open source bastion host and an operation and maintenance security audit system. Prior to v3.10.21-lts and v4.10.12-lts, a low-privileged authenticated user can invoke LDAP configuration tests and start LDAP synchronization by sending crafted messages to the /ws/ldap/ WebSocket endpoint, bypassing authorization checks and potentially exposing LDAP credentials or causing unintended sync operations. This vulnerability is fixed in v3.10.21-lts and v4.10.12-lts.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jumpserver | jumpserver | < 3.10.21-lts>= 4.0.0, < 4.10.12-lts |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
References
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7893-256g-m822 x_refsource_CONFIRM