Vulnerability · Published Oct 27, 2025 · Assigned by GitHub_M
CVE-2025-62784InventoryGui allows item duplication in GUIs which use GuiStorageElement
Medium 5.3
In plain English
A medium-severity security flaw in InventoryGui from Phoenix616. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
InventoryGui is a library for creating chest GUIs for Bukkit/Spigot plugins. Versions before 1.6.5 contain a vulnerability where any plugin using a GUI with the GuiStorageElement and allows taking out items out of that element can allow item duplication when the experimental Bundle item feature is enabled on the server. The vulnerability is resolved in version 1.6.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | de.themoep:inventorygui | 1.6.5 | GHSA-7whh-79j3-7c55 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Phoenix616 | InventoryGui | < 1.6.5 |
Weakness: CWE-837 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N