Vulnerability · Published Oct 27, 2025 · Assigned by GitHub_M
CVE-2025-62782InventoryGUI vulnerable to item duplication via Bundle items when using GuiStorageElement
Medium 5.9
In plain English
A medium-severity security flaw in InventoryGui from Phoenix616. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
InventoryGui is a library for creating chest GUIs for Bukkit/Spigot plugins. Versions 1.6.3-SNAPSHOT and earlier contain a vulnerability where GUIs using GuiStorageElement can allow item duplication when the experimental Bundle item feature is enabled on the server. The vulnerability is resolved in version 1.6.4-SNAPSHOT.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | de.themoep:inventorygui | 1.6.4-SNAPSHOT | GHSA-rgvh-4m82-fvjq |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Phoenix616 | InventoryGui | < 1.6.4-SNAPSHOT |
Weakness: CWE-837 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:H/VA:L/SC:N/SI:L/SA:L