Vulnerability · Published Oct 27, 2025 · Assigned by GitHub_M

CVE-2025-62725Docker Compose Vulnerable to Path Traversal via OCI Artifact Layer Annotations

High 8.9

In plain English

A high-severity path traversal in compose from docker. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 15.8% (higher than 97% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.9High
Exploit odds (30 days)15.8%top 3.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Docker Compose trusts the path information embedded in remote OCI compose artifacts. When a layer includes the annotations com.docker.compose.extends or com.docker.compose.envfile, Compose joins the attacker‑supplied value from com.docker.compose.file/com.docker.compose.envfile with its local cache directory and writes the file there. This affects any platform or workflow that resolves remote OCI compose artifacts, Docker Desktop, standalone Compose binaries on Linux, CI/CD runners, cloud dev environments is affected. An attacker can escape the cache directory and overwrite arbitrary files on the machine running docker compose, even if the user only runs read‑only commands such as docker compose config or docker compose ps. This issue is fixed in v2.40.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14docker-composeno fix listedDEBIAN-CVE-2025-62725
Gogithub.com/docker/composeno fix listedGO-2025-4077
Gogithub.com/docker/compose/v22.40.2GHSA-gv8h-7v7w-r22q
Gogithub.com/docker/compose/v22.40.2GO-2025-4077
Ubuntu:22.04:LTSdocker-composeno fix listedUBUNTU-CVE-2025-62725
Ubuntu:24.04:LTSdocker-composeno fix listedUBUNTU-CVE-2025-62725

Affected products (as reported)

VendorProductVersions
docker compose < 2.40.2

Weakness: CWE-22 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

References