Vulnerability · Published Oct 24, 2025 · Assigned by GitHub_M
CVE-2025-62716Plane Vulnerable to Cross-Site Scripting via Open Redirect in ?next_path Parameter
High 8.1
In plain English
A high-severity cross-site scripting in plane from makeplane. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities).
Official description
Plane is open-source project management software. Prior to version 1.1.0, an open redirect vulnerability in the ?next_path query parameter allows attackers to supply arbitrary schemes (e.g., javascript:) that are passed directly to router.push. This results in a cross-site scripting (XSS) vulnerability, enabling attackers to execute arbitrary JavaScript in the victim’s browser. The issue can be exploited without authentication and has severe impact, including information disclosure, and privilege escalation and modifications of administrative settings. This issue has been patched in version 1.1.0.
Affected products (as reported)
Weakness: CWE-79, CWE-601 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
References
- https://github.com/makeplane/plane/security/advisories/GHSA-6fj7-xgpg-mj6f x_refsource_CONFIRM