Vulnerability · Published Oct 23, 2025 · Assigned by GitHub_M

CVE-2025-62713Kottster app reinitialization can be re-triggered allowing command injection in development mode

High 7.2

In plain English

A high-severity improper access control in kottster from kottster. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.2High
Exploit odds (30 days)0.6%top 50.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kottster is a self hosted Node.js admin panel. From versions 3.2.0 to before 3.3.2, Kottster contains a pre-authentication remote code execution (RCE) vulnerability when running in development mode. This affects development mode only, production deployments were never affected. This issue has been fixed in version 3.3.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@kottster/server3.3.2GHSA-j3w7-9qc3-g96p

Affected products (as reported)

VendorProductVersions
kottster kottster >= 3.2.0, < 3.3.2

Weakness: CWE-284, CWE-78 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

References