Vulnerability · Published Feb 3, 2026 · Assigned by GitHub_M
CVE-2025-62600eprosima Fast DDS affected by Out-of-Memory in readBinaryPropertySeq via Manipulated DATA Submessage when DDS Security is enabled
High 8.6
In plain English
A high-severity integer overflow in Fast-DDS from eProsima. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities).
Official description
eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes an Out-Of-Memory (OOM) condition, resulting in remote termination of Fast-DDS. If the fields of PID_IDENTITY_TOKEN or PID_PERMISSION_TOKEN in the DATA Submessage — specifically by tampering with the length field in readBinaryPropertySeq— are modified, an integer overflow occurs, leading to an OOM during the resize operation. This vulnerability is fixed in 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | fastdds | no fix listed | DEBIAN-CVE-2025-62600 |
| Debian:13 | fastdds | no fix listed | DEBIAN-CVE-2025-62600 |
| Ubuntu:24.04:LTS | fastdds | no fix listed | UBUNTU-CVE-2025-62600 |
| Ubuntu:25.10 | fastdds | no fix listed | UBUNTU-CVE-2025-62600 |
| Ubuntu:26.04:LTS | fastdds | no fix listed | UBUNTU-CVE-2025-62600 |
| Ubuntu:26.10 | fastdds | no fix listed | UBUNTU-CVE-2025-62600 |
Affected products (as reported)
Weakness: CWE-190, CWE-789 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
References
- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-hvm8-mm7f-m6hc x_refsource_CONFIRM