Vulnerability · Published Feb 3, 2026 · Assigned by GitHub_M

CVE-2025-62599eprosima Fast DDS affected by Out-of-Memory in readPropertySeq via Manipulated DATA Submessage when DDS Security is enabled

High 8.6

In plain English

A high-severity integer overflow in Fast-DDS from eProsima. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities).

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.4%top 65.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

eprosima Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group). Prior to 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes an Out-Of-Memory (OOM) condition, resulting in remote termination of Fast-DDS. If the fields of PID_IDENTITY_TOKEN or PID_PERMISSION_TOKEN in the DATA Submessage — specifically by tampering with the length field in readPropertySeq — are modified, an integer overflow occurs, leading to an OOM during the resize operation. This vulnerability is fixed in 2.6.11, 2.14.6, 3.2.4, 3.3.1, and 3.4.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12fastddsno fix listedDEBIAN-CVE-2025-62599
Debian:13fastddsno fix listedDEBIAN-CVE-2025-62599
Ubuntu:24.04:LTSfastddsno fix listedUBUNTU-CVE-2025-62599
Ubuntu:25.10fastddsno fix listedUBUNTU-CVE-2025-62599
Ubuntu:26.04:LTSfastddsno fix listedUBUNTU-CVE-2025-62599
Ubuntu:26.10fastddsno fix listedUBUNTU-CVE-2025-62599

Affected products (as reported)

VendorProductVersions
eProsima Fast-DDS < 2.6.11>= 2.7.0, < 2.14.6>= 3.0.0, < 3.2.4>= 3.3.0, < 3.3.1>= 3.4.0, < 3.4.2

Weakness: CWE-190, CWE-789 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

References