Vulnerability · Published Oct 22, 2025 · Assigned by GitHub_M

CVE-2025-62513OpenBao leaks HTTPRawBody in Audit Logs

Medium 5.7

In plain English

A medium-severity sensitive data in logs in openbao from openbao. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.7Medium
Exploit odds (30 days)0.3%top 75.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

OpenBao is an open source identity-based secrets management system. In versions 2.2.0 to 2.4.1, OpenBao's audit log experienced a regression wherein raw HTTP bodies used by few endpoints were not correctly redacted (HMAC'd). This impacts those using the ACME functionality of PKI, resulting in short-lived ACME verification challenge codes being leaked in the audit logs. Additionally, this impacts those using the OIDC issuer functionality of the identity subsystem, auth and token response codes along with claims could be leaked in the audit logs. ACME verification codes are not usable after verification or challenge expiry so are of limited long-term use. This issue has been patched in OpenBao 2.4.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.22openbao2.4.3-r0ALPINE-CVE-2025-62513
Alpine:v3.23openbao2.4.3-r0ALPINE-CVE-2025-62513
Alpine:v3.24openbao2.4.3-r0ALPINE-CVE-2025-62513
Gogithub.com/openbao/openbao0.0.0-20251022165510-cc2c476bac66GHSA-ghfh-fmx4-26h8
Gogithub.com/openbao/openbao0.0.0-20251022165510-cc2c476bac66GO-2025-4049

Affected products (as reported)

VendorProductVersions
openbao openbao >= 2.2.0, < 2.4.2

Weakness: CWE-532 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References