Vulnerability · Published Oct 16, 2025 · Assigned by GitHub_M

CVE-2025-62427Server-Side Request Forgery (SSRF) in Angular SSR

High 8.7

In plain English

A high-severity server-side request forgery in angular-cli from angular. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.4%top 62.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

The Angular SSR is a server-rise rendering tool for Angular applications. The vulnerability is a Server-Side Request Forgery (SSRF) flaw within the URL resolution mechanism of Angular's Server-Side Rendering package (@angular/ssr) before 19.2.18, 20.3.6, and 21.0.0-next.8. The function createRequestUrl uses the native URL constructor. When an incoming request path (e.g., originalUrl or url) begins with a double forward slash (//) or backslash (\\), the URL constructor treats it as a schema-relative URL. This behavior overrides the security-intended base URL (protocol, host, and port) supplied as the second argument, instead resolving the URL against the scheme of the base URL but adopting the attacker-controlled hostname. This allows an attacker to specify an external domain in the URL path, tricking the Angular SSR environment into setting the page's virtual location (accessible via DOCUMENT or PlatformLocation tokens) to this attacker-controlled domain. Any subsequent relative HTTP requests made during the SSR process (e.g., using HttpClient.get('assets/data.json')) will be incorrectly resolved against the attacker's domain, forcing the server to communicate with an arbitrary external endpoint. This vulnerability is fixed in 19.2.18, 20.3.6, and 21.0.0-next.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@angular/ssr19.2.18GHSA-q63q-pgmf-mxhr
npm@angular/ssr20.3.6GHSA-q63q-pgmf-mxhr
npm@angular/ssr21.0.0-next.8GHSA-q63q-pgmf-mxhr

Affected products (as reported)

VendorProductVersions
angular angular-cli >=19.0.0-next.0, < 19.2.18>=20.0.0-next.0, < 20.3.6>=21.0.0-next.0, < 21.0.0-next.8

Weakness: CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References