Vulnerability · Published Oct 16, 2025 · Assigned by GitHub_M

CVE-2025-62412LibreNMS alert-rules Cross-Site Scripting Vulnerability

Low 3.8

In plain English

A low-severity cross-site scripting in librenms from librenms. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.8Low
Exploit odds (30 days)0.3%top 79.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

LibreNMS is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts > Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistlibrenms/librenms25.10.0GHSA-6g2v-66ch-6xmh

Affected products (as reported)

VendorProductVersions
librenms librenms < 25.10.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N

References