Vulnerability · Published Dec 8, 2025 · Assigned by GitHub_M
CVE-2025-62408c-ares has a Use After Free vulnerability when connection is cleaned up after error
Medium 5.9
In plain English
A medium-severity use-after-free in c-ares from c-ares. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.4%top 62.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
c-ares is an asynchronous resolver library. Versions 1.32.3 through 1.34.5 terminate a query after maximum attempts when using read_answer() and process_answer(), which can cause a Denial of Service. This issue is fixed in version 1.34.6.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.21 | c-ares | 1.34.6-r0 | ALPINE-CVE-2025-62408 |
| Alpine:v3.22 | c-ares | 1.34.6-r0 | ALPINE-CVE-2025-62408 |
| Alpine:v3.23 | c-ares | 1.34.6-r0 | ALPINE-CVE-2025-62408 |
| Alpine:v3.24 | c-ares | 1.34.6-r0 | ALPINE-CVE-2025-62408 |
| Debian:13 | c-ares | 1.34.5-1+deb13u1 | DSA-6084-1 |
| Debian:13 | c-ares | 1.34.5-1+deb13u1 | DEBIAN-CVE-2025-62408 |
| Debian:14 | c-ares | 1.34.6-1 | DEBIAN-CVE-2025-62408 |
| Ubuntu:25.10 | c-ares | 1.34.5-1ubuntu0.1 | UBUNTU-CVE-2025-62408 |
| Ubuntu:25.10 | c-ares | 1.34.5-1ubuntu0.1 | USN-7925-1 |
Affected products (as reported)
Weakness: CWE-416 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H