Vulnerability · Published Nov 21, 2025 · Assigned by GitHub_M
CVE-2025-62372vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs
High 8.3
In plain English
A high-severity security flaw in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | vllm | 0.11.1 | GHSA-pmqf-x6x8-p7qw |
| PyPI | vllm | 0.11.1 | PYSEC-2026-2019 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| vllm-project | vllm | >= 0.5.5, < 0.11.1 |
Weakness: CWE-129 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-pmqf-x6x8-p7qw x_refsource_CONFIRM
- https://github.com/vllm-project/vllm/pull/27204 x_refsource_MISC
- https://github.com/vllm-project/vllm/pull/6613 x_refsource_MISC
- https://github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b x_refsource_MISC