Vulnerability · Published Oct 13, 2025 · Assigned by GitHub_M
CVE-2025-62363yt-grabber-tui allows arbitrary code execution via configurable yt-dlp path
High 7.8
In plain English
A high-severity security flaw in YtGrabber-TUI from zheny-creator. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities).
Official description
yt-grabber-tui is a terminal user interface application for downloading videos. In versions before 1.0-rc, the application allows users to configure the path to the yt-dlp executable via the path_to_yt_dlp configuration setting. An attacker with write access to the configuration file or the filesystem location of the configured executable can replace the executable with malicious code or create a symlink to an arbitrary executable. When the application invokes yt-dlp, the malicious code is executed with the privileges of the user running yt-grabber-tui. This vulnerability has been patched in version 1.0-rc.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| zheny-creator | YtGrabber-TUI | < 1.0-rc |
Weakness: CWE-59 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H