Vulnerability · Published Oct 17, 2025 · Assigned by GitHub_M

CVE-2025-62171ImageMagick vulnerable to denial of service via integer overflow in BMP decoder on 32-bit systems

Medium 5.9

In plain English

A medium-severity integer overflow in ImageMagick from ImageMagick. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.8%top 42.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

ImageMagick is an open source software suite for displaying, converting, and editing raster image files. In ImageMagick versions prior to 7.1.2-7 and 6.9.13-32, an integer overflow vulnerability exists in the BMP decoder on 32-bit systems. The vulnerability occurs in coders/bmp.c when calculating the extent value by multiplying image columns by bits per pixel. On 32-bit systems with size_t of 4 bytes, a malicious BMP file with specific dimensions can cause this multiplication to overflow and wrap to zero. The overflow check added to address CVE-2025-57803 is placed after the overflow occurs, making it ineffective. A specially crafted 58-byte BMP file with width set to 536,870,912 and 32 bits per pixel can trigger this overflow, causing the bytes_per_line calculation to become zero. This vulnerability only affects 32-bit builds of ImageMagick where default resource limits for width, height, and area have been manually increased beyond their defaults. 64-bit systems with size_t of 8 bytes are not vulnerable, and systems using default ImageMagick resource limits are not vulnerable. The vulnerability is fixed in versions 7.1.2-7 and 6.9.13-32.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.22imagemagick7.1.2.8-r0ALPINE-CVE-2025-62171
Alpine:v3.23imagemagick7.1.2.8-r0ALPINE-CVE-2025-62171
Alpine:v3.24imagemagick7.1.2.8-r0ALPINE-CVE-2025-62171
Debian:12imagemagick8:6.9.11.60+dfsg-1.6+deb12u5DEBIAN-CVE-2025-62171
Debian:13imagemagick8:7.1.1.43+dfsg1-1+deb13u3DEBIAN-CVE-2025-62171
Debian:14imagemagick8:7.1.2.7+dfsg1-1DEBIAN-CVE-2025-62171
NuGetmagick.net-q16-anycpu14.9.0GHSA-9pp9-cfwx-54rm
NuGetmagick.net-q16-hdri-anycpu14.9.0GHSA-9pp9-cfwx-54rm
NuGetmagick.net-q16-hdri-x8614.9.0GHSA-9pp9-cfwx-54rm
NuGetmagick.net-q16-x8614.9.0GHSA-9pp9-cfwx-54rm
NuGetmagick.net-q8-anycpu14.9.0GHSA-9pp9-cfwx-54rm
NuGetmagick.net-q8-x8614.9.0GHSA-9pp9-cfwx-54rm
Ubuntu:25.10imagemagickno fix listedUBUNTU-CVE-2025-62171
Ubuntu:26.04:LTSimagemagick8:7.1.2.8+dfsg1-1UBUNTU-CVE-2025-62171

Affected products (as reported)

VendorProductVersions
ImageMagick ImageMagick < 6.9.13-32>= 7.0.0-0, < 7.1.2-7

Weakness: CWE-190 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

References