Vulnerability · Published Nov 21, 2025 · Assigned by GitHub_M

CVE-2025-62164VLLM deserialization vulnerability leading to DoS and potential RCE

High 8.8

In plain English

A high-severity improper input validation in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.0%top 38.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.11.1GHSA-mrw7-hf4f-83pf
PyPIvllm0.11.1PYSEC-2026-2018

Affected products (as reported)

VendorProductVersions
vllm-project vllm >= 0.10.2, < 0.11.1

Weakness: CWE-20, CWE-123, CWE-502, CWE-787 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References