Vulnerability · Published Oct 16, 2025 · Assigned by GitHub_M
CVE-2025-61924PrestaShop Checkout Target PayPal merchant account hijacking from backoffice
Low 3.8
In plain English
A low-severity security flaw in ps_checkout from PrestaShopCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 19% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | prestashop/ps_checkout | 4.4.1 | GHSA-wvpg-4wrh-5889 |
| Packagist | prestashop/ps_checkout | 5.0.5 | GHSA-wvpg-4wrh-5889 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| PrestaShopCorp | ps_checkout | < 4.4.1>= 5.0.0, < 5.0.5 |
Weakness: CWE-184 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N