Vulnerability · Published Oct 16, 2025 · Assigned by GitHub_M
CVE-2025-61922PrestaShop Checkout allows customer account takeover via email
Critical 9.1
In plain English
A critical-severity improper authentication in ps_checkout from PrestaShopCorp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. Starting in version 1.3.0 and prior to versions 4.4.1 and 5.0.5, missing validation on the Express Checkout feature allows silent login, enabling account takeover via email. The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | prestashop/ps_checkout | 4.4.1 | GHSA-54hq-mf6h-48xh |
| Packagist | prestashop/ps_checkout | 5.0.5 | GHSA-54hq-mf6h-48xh |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| PrestaShopCorp | ps_checkout | >= 1.3.0, < 4.4.1>= 5.0.0, < 5.0.5 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N