Vulnerability · Published Oct 10, 2025 · Assigned by GitHub_M
CVE-2025-61919Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing
High 7.5
In plain English
A high-severity uncontrolled resource consumption in rack from rack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Rack is a modular Ruby web server interface. Prior to versions 2.2.20, 3.1.18, and 3.2.3, `Rack::Request#POST` reads the entire request body into memory for `Content-Type: application/x-www-form-urlencoded`, calling `rack.input.read(nil)` without enforcing a length or cap. Large request bodies can therefore be buffered completely into process memory before parsing, leading to denial of service (DoS) through memory exhaustion. Users should upgrade to Rack version 2.2.20, 3.1.18, or 3.2.3, anu of which enforces form parameter limits using `query_parser.bytesize_limit`, preventing unbounded reads of `application/x-www-form-urlencoded` bodies. Additionally, enforce strict maximum body size at the proxy or web server layer (e.g., Nginx `client_max_body_size`, Apache `LimitRequestBody`).
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | cockpit-ha-cluster | 0.12.1-1.el10_1.1 | ALSA-2025:21036 |
| AlmaLinux:8 | pcs | 0.10.18-2.el8_10.7.alma.1 | ALSA-2025:19719 |
| AlmaLinux:9 | pcs | 0.11.10-1.el9_7.1 | ALSA-2025:20962 |
| AlmaLinux:8 | pcs-snmp | 0.10.18-2.el8_10.7.alma.1 | ALSA-2025:19719 |
| AlmaLinux:9 | pcs-snmp | 0.11.10-1.el9_7.1 | ALSA-2025:20962 |
| Debian:12 | ruby-rack | 2.2.20-0+deb12u1 | DSA-6048-1 |
| Debian:12 | ruby-rack | 2.2.20-0+deb12u1 | DEBIAN-CVE-2025-61919 |
| Debian:13 | ruby-rack | 3.1.18-1~deb13u1 | DEBIAN-CVE-2025-61919 |
| Debian:13 | ruby-rack | 3.1.18-1~deb13u1 | DSA-6048-1 |
| Debian:14 | ruby-rack | 3.1.18-1 | DEBIAN-CVE-2025-61919 |
| Rocky Linux:8 | pcs | 0:0.10.18-2.el8_10.7 | RLSA-2025:19719 |
| Rocky Linux:9 | pcs | 0:0.11.10-1.el9_7.1 | RLSA-2025:20962 |
| Rocky Linux:9 | pcs | 0:0.11.9-2.el9_6.2 | RLSA-2025:19512 |
| RubyGems | rack | 3.1.18 | GHSA-6xw4-3v39-52mm |
| RubyGems | rack | 2.2.20 | GHSA-6xw4-3v39-52mm |
| RubyGems | rack | 3.2.3 | GHSA-6xw4-3v39-52mm |
| Ubuntu:22.04:LTS | ruby-rack | 2.1.4-5ubuntu1.2 | UBUNTU-CVE-2025-61919 |
| Ubuntu:24.04:LTS | ruby-rack | 2.2.7-1ubuntu0.5 | UBUNTU-CVE-2025-61919 |
| Ubuntu:25.10 | ruby-rack | 3.1.16-0.1ubuntu0.1 | UBUNTU-CVE-2025-61919 |
Affected products (as reported)
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/rack/rack/security/advisories/GHSA-6xw4-3v39-52mm x_refsource_CONFIRM
- https://github.com/rack/rack/commit/4e2c903991a790ee211a3021808ff4fd6fe82881 x_refsource_MISC
- https://github.com/rack/rack/commit/cbd541e8a3d0c5830a3c9a30d3718ce2e124f9db x_refsource_MISC
- https://github.com/rack/rack/commit/e179614c4a653283286f5f046428cbb85f21146f x_refsource_MISC