Vulnerability · Published Nov 29, 2025 · Assigned by GitHub_M
CVE-2025-61915OpenPrinting CUPS vulnerable to stack based out-of-bound write
Medium 6.0
In plain English
A medium-severity security flaw in cups from OpenPrinting. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | cups | 1:2.2.6-66.el8_10 | ALSA-2026:0596 |
| AlmaLinux:9 | cups | 1:2.3.3op2-34.el9_7.2 | ALSA-2026:0312 |
| AlmaLinux:8 | cups-client | 1:2.2.6-66.el8_10 | ALSA-2026:0596 |
| AlmaLinux:9 | cups-client | 1:2.3.3op2-34.el9_7.2 | ALSA-2026:0312 |
| AlmaLinux:8 | cups-devel | 1:2.2.6-66.el8_10 | ALSA-2026:0596 |
| AlmaLinux:9 | cups-devel | 1:2.3.3op2-34.el9_7.2 | ALSA-2026:0312 |
| AlmaLinux:10 | cups-filesystem | 1:2.4.10-12.el10_1.2 | ALSA-2026:0464 |
| AlmaLinux:8 | cups-filesystem | 1:2.2.6-66.el8_10 | ALSA-2026:0596 |
| AlmaLinux:9 | cups-filesystem | 1:2.3.3op2-34.el9_7.2 | ALSA-2026:0312 |
| AlmaLinux:8 | cups-ipptool | 1:2.2.6-66.el8_10 | ALSA-2026:0596 |
| AlmaLinux:9 | cups-ipptool | 1:2.3.3op2-34.el9_7.2 | ALSA-2026:0312 |
| AlmaLinux:8 | cups-libs | 1:2.2.6-66.el8_10 | ALSA-2026:0596 |
| AlmaLinux:9 | cups-libs | 1:2.3.3op2-34.el9_7.2 | ALSA-2026:0312 |
| AlmaLinux:8 | cups-lpd | 1:2.2.6-66.el8_10 | ALSA-2026:0596 |
| AlmaLinux:9 | cups-lpd | 1:2.3.3op2-34.el9_7.2 | ALSA-2026:0312 |
| AlmaLinux:9 | cups-printerapp | 1:2.3.3op2-34.el9_7.2 | ALSA-2026:0312 |
| Alpine:v3.20 | cups | 2.4.16-r0 | ALPINE-CVE-2025-61915 |
| Alpine:v3.21 | cups | 2.4.16-r0 | ALPINE-CVE-2025-61915 |
| Alpine:v3.22 | cups | 2.4.16-r0 | ALPINE-CVE-2025-61915 |
| Alpine:v3.23 | cups | 2.4.16-r0 | ALPINE-CVE-2025-61915 |
| Alpine:v3.24 | cups | 2.4.16-r0 | ALPINE-CVE-2025-61915 |
| Debian:12 | cups | no fix listed | DEBIAN-CVE-2025-61915 |
| Debian:13 | cups | no fix listed | DEBIAN-CVE-2025-61915 |
| Debian:14 | cups | 2.4.15-1 | DEBIAN-CVE-2025-61915 |
| Rocky Linux:10 | cups | 1:2.4.10-12.el10_1.2 | RLSA-2026:0464 |
| Rocky Linux:8 | cups | 1:2.2.6-66.el8_10 | RLSA-2026:0596 |
| Rocky Linux:9 | cups | 1:2.3.3op2-34.el9_7.2 | RLSA-2026:0312 |
| Ubuntu:22.04:LTS | cups | 2.4.1op1-1ubuntu4.15 | USN-7897-1 |
| Ubuntu:22.04:LTS | cups | 2.4.1op1-1ubuntu4.15 | UBUNTU-CVE-2025-61915 |
| Ubuntu:24.04:LTS | cups | 2.4.7-1.2ubuntu7.7 | USN-7897-1 |
| Ubuntu:24.04:LTS | cups | 2.4.7-1.2ubuntu7.7 | UBUNTU-CVE-2025-61915 |
| Ubuntu:25.10 | cups | 2.4.12-0ubuntu3.3 | USN-7897-1 |
| Ubuntu:25.10 | cups | 2.4.12-0ubuntu3.3 | UBUNTU-CVE-2025-61915 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenPrinting | cups | < 2.4.15 |
Weakness: CWE-129, CWE-124 · Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H
References
- https://github.com/OpenPrinting/cups/security/advisories/GHSA-hxm8-vfpq-jrfc x_refsource_CONFIRM
- https://github.com/OpenPrinting/cups/commit/db8d560262c22a21ee1e55dfd62fa98d9359bcb0 x_refsource_MISC
- https://github.com/OpenPrinting/cups/releases/tag/v2.4.15 x_refsource_MISC
- http://www.openwall.com/lists/oss-security/2025/11/27/5