Vulnerability · Published Oct 8, 2025 · Assigned by GitHub_M

CVE-2025-61788Opencast Paella Player 7 vulnerable to Cross-Site-Scripting

Medium 5.1

In plain English

A medium-severity cross-site scripting in opencast from opencast. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities).

Severity (CVSS 4.0)5.1Medium
Exploit odds (30 days)0.2%top 87.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Opencast is a free, open-source platform to support the management of educational audio and video content. Prior to Opencast 17.8 and 18.2, the paella would include and render some user inputs (metadata like title, description, etc.) unfiltered and unmodified. The vulnerability allows attackers to inject and malicious HTML and JavaScript in the player, which would then be executed in the browsers of users watching the prepared media. This can then be used to modify the site or to execute actions in the name of logged-in users. To inject malicious metadata, an attacker needs write access to the system. For example, the ability to upload media and modify metadata. This cannot be exploited by unauthenticated users. This issue is fixed in Opencast 17.8 and 18.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.opencastproject:opencast-commonno fix listedGHSA-m2vg-rmq6-p62r

Affected products (as reported)

VendorProductVersions
opencast opencast < 17.8>= 18.0, < 18.2

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

References