Vulnerability · Published Oct 6, 2025 · Assigned by GitHub_M

CVE-2025-61765python-socketio vulnerable to arbitrary Python code execution (RCE) through malicious pickle deserialization in certain multi-server deployments

Medium 6.4

In plain English

A medium-severity unsafe deserialization in python-socketio from miguelgrinberg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.4Medium
Exploit odds (30 days)0.5%top 58.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

python-socketio is a Python implementation of the Socket.IO realtime client and server. A remote code execution vulnerability in python-socketio versions prior to 5.14.0 allows attackers to execute arbitrary Python code through malicious pickle deserialization in multi-server deployments on which the attacker previously gained access to the message queue that the servers use for internal communications. When Socket.IO servers are configured to use a message queue backend such as Redis for inter-server communication, messages sent between the servers are encoded using the `pickle` Python module. When a server receives one of these messages through the message queue, it assumes it is trusted and immediately deserializes it. The vulnerability stems from deserialization of messages using Python's `pickle.loads()` function. Having previously obtained access to the message queue, the attacker can send a python-socketio server a crafted pickle payload that executes arbitrary code during deserialization via Python's `__reduce__` method. This vulnerability only affects deployments with a compromised message queue. The attack can lead to the attacker executing random code in the context of, and with the privileges of a Socket.IO server process. Single-server systems that do not use a message queue, and multi-server systems with a secure message queue are not vulnerable. In addition to making sure standard security practices are followed in the deployment of the message queue, users of the python-socketio package can upgrade to version 5.14.0 or newer, which remove the `pickle` module and use the much safer JSON encoding for inter-server messaging.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12python-socketiono fix listedDEBIAN-CVE-2025-61765
Debian:13python-socketiono fix listedDEBIAN-CVE-2025-61765
Debian:14python-socketio5.16.0-1DEBIAN-CVE-2025-61765
PyPIpython-socketio5.14.0GHSA-g8c6-8fjj-2r4m
PyPIpython-socketio5.14.0PYSEC-2026-1854
Ubuntu:22.04:LTSpython-socketiono fix listedUBUNTU-CVE-2025-61765
Ubuntu:24.04:LTSpython-socketiono fix listedUBUNTU-CVE-2025-61765
Ubuntu:25.10python-socketiono fix listedUBUNTU-CVE-2025-61765
Ubuntu:26.04:LTSpython-socketiono fix listedUBUNTU-CVE-2025-61765
Ubuntu:26.10python-socketiono fix listedUBUNTU-CVE-2025-61765

Affected products (as reported)

VendorProductVersions
miguelgrinberg python-socketio >= 0.8.0, < 5.14.0

Weakness: CWE-502 · Vector: CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L

References