Vulnerability · Published Sep 29, 2025 · Assigned by GitHub_M

CVE-2025-59954Knowage Contains a Remote Code Execution Vulnerability

Critical 9.3

In plain English

A critical-severity code injection in Knowage-Server from KnowageLabs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities).

Severity (CVSS 4.0)9.3Critical
Exploit odds (30 days)0.5%top 53.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Knowage is an open source analytics and business intelligence suite. Versions 8.1.26 and below are vulnerable to Remote Code Exection through using an unsafe org.apache.commons.jxpath.JXPathContext in MetaService.java service. This issue is fixed in version 8.1.27.

Affected products (as reported)

VendorProductVersions
KnowageLabs Knowage-Server < 8.1.27

Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P

References