Vulnerability · Published Sep 29, 2025 · Assigned by GitHub_M
CVE-2025-59940mkdocs-include-markdown-plugin susceptible to unvalidated input colliding with substitution placeholders
Medium 6.5
In plain English
A medium-severity improper input validation in mkdocs-include-markdown-plugin from mondeja. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.3%top 72.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | mkdocs-include-markdown-plugin | 7.1.8 | GHSA-v39m-5m9j-m9w9 |
| PyPI | mkdocs-include-markdown-plugin | 7.1.8 | PYSEC-2026-1632 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| mondeja | mkdocs-include-markdown-plugin | < 7.1.8 |
Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
References
- https://github.com/mondeja/mkdocs-include-markdown-plugin/security/advisories/GHSA-v39m-5m9j-m9w9 x_refsource_CONFIRM
- https://github.com/mondeja/mkdocs-include-markdown-plugin/issues/274 x_refsource_MISC
- https://github.com/mondeja/mkdocs-include-markdown-plugin/pull/277 x_refsource_MISC
- https://github.com/mondeja/mkdocs-include-markdown-plugin/commit/7466d67aa0de8ffbc427204ad2475fed07678915 x_refsource_MISC