Vulnerability · Published Sep 26, 2025 · Assigned by GitHub_M

CVE-2025-59842JupyterLab LaTeX typesetter links did not enforce `noopener` attribute

Low 2.1

In plain English

A low-severity security flaw in jupyterlab from jupyterlab. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.1Low
Exploit odds (30 days)0.2%top 84.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. Prior to version 4.4.8, links generated with LaTeX typesetters in Markdown files and Markdown cells in JupyterLab and Jupyter Notebook did not include the noopener attribute. This is deemed to have no impact on the default installations. Theoretically users of third-party LaTeX-rendering extensions could find themselves vulnerable to reverse tabnabbing attacks if links generated by those extensions included target=_blank (no such extensions are known at time of writing) and they were to click on a link generated in LaTeX (typically visibly different from other links). This issue has been patched in version 4.4.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13jupyterlabno fix listedDEBIAN-CVE-2025-59842
Debian:14jupyterlab4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3DEBIAN-CVE-2025-59842
PyPIjupyterlab4.4.8PYSEC-2026-1482
PyPIjupyterlab4.4.8GHSA-vvfj-2jqx-52jm
Ubuntu:25.10jupyterlabno fix listedUBUNTU-CVE-2025-59842
Ubuntu:26.04:LTSjupyterlabno fix listedUBUNTU-CVE-2025-59842
Ubuntu:26.10jupyterlabno fix listedUBUNTU-CVE-2025-59842

Affected products (as reported)

VendorProductVersions
jupyterlab jupyterlab < 4.4.8

Weakness: CWE-1022 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

References