Vulnerability · Published Nov 13, 2025 · Assigned by GitHub_M

CVE-2025-59840Vega Cross-Site Scripting (XSS) via expressions abusing toString calls in environments using the VEGA_DEBUG global variable

High 8.1

In plain English

A high-severity cross-site scripting in vega from vega. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.4%top 63.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 6.2.0, applications meeting 2 conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. They are vulnerable if they use `vega` in an application that attaches `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window` and if they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). Patches are available in the following Vega applications. If using the latest Vega line (6.x), upgrade to `vega` `6.2.0` / `vega-expression` `6.1.0` / `vega-interpreter` `2.2.1` (if using AST evaluator mode). If using Vega in a non-ESM environment, upgrade to `vega-expression` `5.2.1` / `1.2.1` (if using AST evaluator mode). Some workarounds are available. Do not attach `vega` View instances to global variables, and do not attach `vega` to the global window. These practices of attaching the vega library and View instances may be convenient for debugging, but should not be used in production or in any situation where vega/vega-lite definitions could be provided by untrusted parties.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12vega.jsno fix listedDEBIAN-CVE-2025-59840
Debian:13vega.jsno fix listedDEBIAN-CVE-2025-59840
Debian:14vega.js5.33.1+ds+~cs5.3.0-4DEBIAN-CVE-2025-59840
Ubuntu:24.04:LTSvega.jsno fix listedUBUNTU-CVE-2025-59840
Ubuntu:25.10vega.jsno fix listedUBUNTU-CVE-2025-59840
Ubuntu:26.04:LTSvega.jsno fix listedUBUNTU-CVE-2025-59840
Ubuntu:26.10vega.jsno fix listedUBUNTU-CVE-2025-59840
npmvega6.2.0GHSA-7f2v-3qq3-vvjf
npmvega-expression5.2.1GHSA-7f2v-3qq3-vvjf
npmvega-expression6.1.0GHSA-7f2v-3qq3-vvjf
npmvega-interpreter1.2.1GHSA-7f2v-3qq3-vvjf
npmvega-interpreter2.2.1GHSA-7f2v-3qq3-vvjf

Affected products (as reported)

VendorProductVersions
vega vega vega < 6.2.0vega-expression >= 6.0.0, < 6.1.0vega-expression < 5.2.1vega-interpreter >= 2.0.0, < 2.2.1vega-interpreter < 1.2.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

References