Vulnerability · Published Sep 25, 2025 · Assigned by GitHub_M

CVE-2025-59831`git-comiters` Command Injection vulnerability

High 8.7

In plain English

A high-severity command injection in git-commiters.js from snowyu. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 4.2% (higher than 91% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)4.2%top 9.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

git-commiters is a Node.js function module providing committers stats for their git repository. Prior to version 0.1.2, there is a command injection vulnerability in git-commiters. This vulnerability manifests with the library's primary exported API: gitCommiters(options, callback) which allows specifying options such as cwd for current working directory and revisionRange as a revision pointer, such as HEAD. However, the library does not sanitize for user input or practice secure process execution API to separate commands from their arguments and as such, uncontrolled user input is concatenated into command execution. This issue has been patched in version 0.1.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmgit-commiters0.1.2GHSA-g38c-wxjf-xrh6

Affected products (as reported)

VendorProductVersions
snowyu git-commiters.js < 0.1.2

Weakness: CWE-77, CWE-78 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References