Vulnerability · Published Sep 23, 2025 · Assigned by GitHub_M
CVE-2025-59546DNN Vulnerable to Stored XSS Using Backend Admin Credentials
Low 2.4
In plain English
A low-severity cross-site scripting in Dnn.Platform from dnnsoftware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 10.1.0, administrators and content editors can set html in module titles that could include javascript which could be used for XSS based attacks. This issue has been patched in version 10.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| NuGet | dotnetnuke.core | 10.1.0 | GHSA-gj8m-5492-q98h |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| dnnsoftware | Dnn.Platform | < 10.1.0 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N