Vulnerability · Published Sep 22, 2025 · Assigned by GitHub_M

CVE-2025-59528Flowise has Remote Code Execution vulnerability

Critical 10.0

In plain English

A critical-severity code injection in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 86.5% (higher than 99.7% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)86.5%top 0.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling3Metasploit, Nuclei, Public PoC

Official description

Flowise is a drag & drop user interface to build a customized large language model flow. In version 3.0.5, Flowise is vulnerable to remote code execution. The CustomMCP node allows users to input configuration settings for connecting to an external MCP server. This node parses the user-provided mcpServerConfig string to build the MCP server configuration. However, during this process, it executes JavaScript code without any security validation. Specifically, inside the convertToValidJSONString function, user input is directly passed to the Function() constructor, which evaluates and executes the input as JavaScript code. Since this runs with full Node.js runtime privileges, it can access dangerous modules such as child_process and fs. This issue has been patched in version 3.0.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmflowise3.0.6GHSA-3gcm-f6qx-ff7p

Affected products (as reported)

VendorProductVersions
FlowiseAI Flowise = 3.0.5

Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

References