Vulnerability · Published Sep 19, 2025 · Assigned by GitHub_M

CVE-2025-59427Cloudflare vite plugin exposes secrets over the built-in dev server

Low 2.9

In plain English

A low-severity information exposure in workers-sdk from cloudflare. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.9Low
Exploit odds (30 days)0.4%top 67.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

The Cloudflare Vite plugin enables a full-featured integration between Vite and the Workers runtime. When utilising the Cloudflare Vite plugin in its default configuration, all files are exposed by the local dev server, including files in the root directory that contain secret information such as .env and .dev.vars. This vulnerability is fixed in 1.6.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@cloudflare/vite-plugin1.6.0GHSA-4pfg-2mw5-f8jx

Affected products (as reported)

VendorProductVersions
cloudflare workers-sdk < 1.6.0

Weakness: CWE-200 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P

References