Vulnerability · Published Sep 22, 2025 · Assigned by GitHub_M
CVE-2025-59420Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)
High 7.5
In plain English
A high-severity insufficient verification of data authenticity in authlib from authlib. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.4, Authlib’s JWS verification accepts tokens that declare unknown critical header parameters (crit), violating RFC 7515 “must‑understand” semantics. An attacker can craft a signed token with a critical header (for example, bork or cnf) that strict verifiers reject but Authlib accepts. In mixed‑language fleets, this enables split‑brain verification and can lead to policy bypass, replay, or privilege escalation. This issue has been patched in version 1.6.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | python-authlib | 1.2.0-1+deb12u1 | DEBIAN-CVE-2025-59420 |
| Debian:13 | python-authlib | 1.6.0-1+deb13u1 | DEBIAN-CVE-2025-59420 |
| Debian:14 | python-authlib | 1.6.4-1 | DEBIAN-CVE-2025-59420 |
| PyPI | authlib | 1.6.4 | PYSEC-2026-1200 |
| PyPI | authlib | 1.6.4 | GHSA-9ggr-2464-2j32 |
| Ubuntu:25.10 | python-authlib | no fix listed | UBUNTU-CVE-2025-59420 |
| Ubuntu:26.10 | python-authlib | no fix listed | UBUNTU-CVE-2025-59420 |
Affected products (as reported)
Weakness: CWE-345, CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N