Vulnerability · Published Oct 15, 2025 · Assigned by GitHub_M

CVE-2025-59419Netty netty-codec-smtp SMTP Command Injection Vulnerability Allowing Email Forgery

Medium 5.5

In plain English

A medium-severity security flaw in netty from netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 75% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.5Medium
Exploit odds (30 days)1.6%top 24.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.128.Final and 4.2.7.Final, the SMTP codec in Netty contains an SMTP command injection vulnerability due to insufficient input validation for Carriage Return (\r) and Line Feed (\n) characters in user-supplied parameters. The vulnerability exists in io.netty.handler.codec.smtp.DefaultSmtpRequest, where parameters are directly concatenated into the SMTP command string without sanitization. When methods such as SmtpRequests.rcpt(recipient) are called with a malicious string containing CRLF sequences, attackers can inject arbitrary SMTP commands. Because the injected commands are sent from the server's trusted IP address, resulting emails will likely pass SPF and DKIM authentication checks, making them appear legitimate. This allows remote attackers who can control SMTP command parameters (such as email recipients) to forge arbitrary emails from the trusted server, potentially impersonating executives and forging high-stakes corporate communications. This issue has been patched in versions 4.1.129.Final and 4.2.8.Final. No known workarounds exist.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12netty1:4.1.48-7+deb12u2DEBIAN-CVE-2025-59419
Debian:12netty1:4.1.48-7+deb12u2DSA-6160-1
Debian:13netty1:4.1.48-10+deb13u1DSA-6160-1
Debian:13netty1:4.1.48-10+deb13u1DEBIAN-CVE-2025-59419
Debian:14netty1:4.1.48-11DEBIAN-CVE-2025-59419
Mavenio.netty:netty-codec-smtp4.1.128.FinalGHSA-jq43-27x9-3v86
Mavenio.netty:netty-codec-smtp4.2.7.FinalGHSA-jq43-27x9-3v86
Ubuntu:25.10netty1:4.1.48-10ubuntu0.25.10.1USN-7843-1
Ubuntu:25.10netty1:4.1.48-10ubuntu0.25.10.1UBUNTU-CVE-2025-59419
Ubuntu:26.10nettyno fix listedUBUNTU-CVE-2025-59419

Affected products (as reported)

VendorProductVersions
netty netty < 4.2.7.Final>= 4.2.0.Alpha1, < 4.1.128.Final

Weakness: CWE-93 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

References