Vulnerability · Published Sep 17, 2025 · Assigned by GitHub_M
CVE-2025-59350Timing attacks against Proxy’s basic authentication are possible
Low 2.7
In plain English
A low-severity security flaw in dragonfly from dragonflyoss. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Dragonfly is an open source P2P-based file distribution and image acceleration system. Prior to 2.1.0, the access control mechanism for the Proxy feature uses simple string comparisons and is therefore vulnerable to timing attacks. An attacker may try to guess the password one character at a time by sending all possible characters to a vulnerable mechanism and measuring the comparison instruction’s execution times. This vulnerability is fixed in 2.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | d7y.io/dragonfly/v2 | 2.1.0 | GHSA-c2fc-9q9c-5486 |
| Go | d7y.io/dragonfly/v2 | 2.1.0 | GO-2025-3972 |
| Go | github.com/dragonflyoss/dragonfly | 2.1.0 | GHSA-c2fc-9q9c-5486 |
| Go | github.com/dragonflyoss/dragonfly | no fix listed | GO-2025-3972 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| dragonflyoss | dragonfly | < 2.1.0 |
Weakness: CWE-208 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U