Vulnerability · Published Sep 16, 2025 · Assigned by cisa-cg

CVE-2025-59270psPAS does not enforce TLS 1.2 within Get-PASSAMLResponse

Low 3.1

In plain English

A low-severity security flaw in psPAS from pspete. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities).

Severity (CVSS 3.1)3.1Low
Exploit odds (30 days)0.2%top 85.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

psPAS PowerShell module does not explicitly enforce TLS 1.2 within the 'Get-PASSAMLResponse' function during the SAML authentication process. An unauthenticated attacker in a 'Man-in-the-Middle' position could manipulate the TLS handshake and downgrade TLS to a deprecated protocol. Fixed in 7.0.209.

Affected products (as reported)

VendorProductVersions
pspete psPAS 6.4.85 – before 7.0.209

Weakness: CWE-757 · Vector: CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

References