Vulnerability · Published Sep 29, 2025 · Assigned by GitHub_M
CVE-2025-59163vet MCP Server SSE Transport DNS Rebinding Vulnerability
Low 2.1
In plain English
A low-severity security flaw in vet from safedep. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
vet is an open source software supply chain security tool. Versions 1.12.4 and below are vulnerable to a DNS rebinding attack due to lack of HTTP Host and Origin header validation. Data from the vet scan sqlite3 database may be exposed to remote attackers when vet is used as an MCP server in SSE mode with default ports through the sqlite3 query MCP tool. This issue is fixed in version 1.12.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/safedep/vet | 1.12.5 | GO-2025-3986 |
| Go | github.com/safedep/vet | 1.12.5 | GHSA-6q9c-m9fr-865m |
Affected products (as reported)
Weakness: CWE-350 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/safedep/vet/security/advisories/GHSA-6q9c-m9fr-865m x_refsource_CONFIRM
- https://github.com/safedep/vet/commit/0ae3560ba11846375812377299fe078d45cc3d48 x_refsource_MISC
- https://github.com/safedep/vet/releases/tag/v1.12.5 x_refsource_MISC