Vulnerability · Published Sep 10, 2025 · Assigned by GitHub_M

CVE-2025-59041Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email

High 8.7

In plain English

A high-severity code injection in claude-code from anthropics. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 54.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Claude Code is an agentic coding tool. At startup, Claude Code executed a command templated in with `git config user.email`. Prior to version 1.0.105, a maliciously configured user email in git could be used to trigger arbitrary code execution before a user accepted the workspace trust dialog. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@anthropic-ai/claude-code1.0.105GHSA-j4h9-wv2m-wrf7

Affected products (as reported)

VendorProductVersions
anthropics claude-code < 1.0.105

Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References