Vulnerability · Published Sep 9, 2025 · Assigned by GitHub_M
CVE-2025-59036Infrahub allows authentication with deleted and expired API tokens
Medium 5.5
In plain English
A medium-severity security flaw in infrahub from opsmill. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | infrahub-server | 1.3.9 | GHSA-v2p7-4pv4-3wwh |
| PyPI | infrahub-server | 1.4.5 | GHSA-v2p7-4pv4-3wwh |
| PyPI | infrahub-server | 1.3.9, 1.4.5 | PYSEC-2026-1463 |
Affected products (as reported)
Weakness: CWE-298 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
References
- https://github.com/opsmill/infrahub/security/advisories/GHSA-v2p7-4pv4-3wwh x_refsource_CONFIRM