Vulnerability · Published Sep 10, 2025 · Assigned by GitHub_M
CVE-2025-59035Indico vulnerable to Cross-Site Scripting via LaTeX math code
Medium 4.6
In plain English
A medium-severity cross-site scripting in indico from indico. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, there is a Cross-Site-Scripting vulnerability when rendering LaTeX math code in contribution or abstract descriptions. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, only let trustworthy users create content on Indico. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | indico | 3.3.8 | GHSA-7cf7-9wrr-vrf4 |
| PyPI | indico | 3.3.8 | PYSEC-2026-1461 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
References
- https://github.com/indico/indico/security/advisories/GHSA-7cf7-9wrr-vrf4 x_refsource_CONFIRM
- https://github.com/indico/indico/releases/tag/v3.3.8 x_refsource_MISC