Vulnerability · Published Oct 1, 2025 · Assigned by GitHub_M
CVE-2025-58769auth0-PHP: Improper File Type Handling in Bulk User Import
Low 3.3
In plain English
A low-severity path traversal in laravel-auth0 from auth0. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
auth0-PHP is an SDK for Auth0 Authentication and Management APIs. In versions 3.3.0 through 8.16.0, the Bulk User Import endpoint in applications built with the SDK does not validate the file-path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. The vulnerability affects any application that either directly uses the Auth0-PHP SDK (versions 3.3.0–8.16.0) or indirectly relies on those versions through the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs. This issue is fixed in version 8.17.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | auth0/auth0-php | 8.17.0 | GHSA-9mh6-g99m-ppcw |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| auth0 | laravel-auth0 | >= 3.3.0, < 8.17.0 |
Weakness: CWE-22, CWE-73 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-hjfh-5jmm-xr24 x_refsource_CONFIRM
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-9mh6-g99m-ppcw x_refsource_MISC
- https://github.com/auth0/symfony/security/advisories/GHSA-7jp2-5h22-m432 x_refsource_MISC
- https://github.com/auth0/wordpress/security/advisories/GHSA-w22c-pw5m-482x x_refsource_MISC
- https://github.com/auth0/auth0-PHP/commit/9026da58f5c381cd4cb5932de829eff6eacbb65c x_refsource_MISC
- https://github.com/auth0/auth0-PHP/releases/tag/8.17.0 x_refsource_MISC