Vulnerability · Published Sep 10, 2025 · Assigned by GitHub_M
CVE-2025-58764Claude Code rg command had Command Injection that allowed bypass of user approval prompt for command execution
High 8.7
In plain English
A high-severity code injection in claude-code from anthropics. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Claude Code is an agentic coding tool. Due to an error in command parsing, versions prior to 1.0.105 were vulnerable to a bypass of the Claude Code confirmation prompt to trigger execution of an untrusted command. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @anthropic-ai/claude-code | 1.0.105 | GHSA-qxfv-fcpc-w36x |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| anthropics | claude-code | < 1.0.105 |
Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N