Vulnerability · Published Sep 9, 2025 · Assigned by GitHub_M
CVE-2025-58758TinyEnv: Missing .env file not required — may cause unexpected behavior
Medium 5.1
In plain English
A medium-severity security flaw in tiny-env from datahihi1. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
TinyEnv is an environment variable loader for PHP applications. In versions 1.0.1, 1.0.2, 1.0.9, and 1.0.10, TinyEnv did not require the `.env` file to exist when loading environment variables. This could lead to unexpected behavior where the application silently ignores missing configuration, potentially causing insecure defaults or deployment misconfigurations. The issue has been fixed in version 1.0.11. All users should upgrade to 1.0.11 or later. As a workaround, users can manually verify the existence of the `.env` file before initializing TinyEnv.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | datahihi1/tiny-env | 1.0.3 | GHSA-3j7m-5g4q-gfpc |
| Packagist | datahihi1/tiny-env | 1.0.11 | GHSA-3j7m-5g4q-gfpc |
Affected products (as reported)
Weakness: CWE-703 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N