Vulnerability · Published Sep 8, 2025 · Assigned by GitHub_M

CVE-2025-58444MCP Inspector is Vulnerable to Potential Command Execution via XSS When Connecting to an Untrusted MCP Server

High 8.6

In plain English

A high-severity security flaw in inspector from modelcontextprotocol. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.6High
Exploit odds (30 days)0.7%top 46.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The MCP inspector is a developer tool for testing and debugging MCP servers. A cross-site scripting issue was reported in versions of the MCP Inspector local development tool prior to 0.16.6 when connecting to untrusted remote MCP servers with a malicious redirect URI. This could be leveraged to interact directly with the inspector proxy to trigger arbitrary command execution. Users are advised to update to 0.16.6 to resolve this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@modelcontextprotocol/inspector0.16.6GHSA-g9hg-qhmf-q45m

Affected products (as reported)

VendorProductVersions
modelcontextprotocol inspector < 0.16.6

Weakness: CWE-84 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References