Vulnerability · Published Sep 6, 2025 · Assigned by GitHub_M
CVE-2025-58438internetarchive is vulnerable to Directory Traversal through file downloads
Critical 9.4
In plain English
A critical-severity path traversal in internetarchive from jjjake. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
internetarchive is a Python and Command-Line Interface to Archive.org In versions 5.5.0 and below, there is a directory traversal (path traversal) vulnerability in the File.download() method of the internetarchive library. The file.download() method does not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., ../../../../windows/system32/file.txt) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory. An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected. This issue is fixed in version 5.5.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | python-internetarchive | 3.3.0-2~deb12u1 | DSA-6035-1 |
| Debian:12 | python-internetarchive | 3.3.0-2~deb12u1 | DEBIAN-CVE-2025-58438 |
| Debian:13 | python-internetarchive | 5.4.0-2~deb13u1 | DEBIAN-CVE-2025-58438 |
| Debian:13 | python-internetarchive | 5.4.0-2~deb13u1 | DSA-6035-1 |
| Debian:14 | python-internetarchive | 5.5.1-1 | DEBIAN-CVE-2025-58438 |
| PyPI | internetarchive | 5.5.1 | PYSEC-2026-357 |
| PyPI | internetarchive | 5.5.1 | GHSA-wx3r-v6h7-frjp |
| Ubuntu:22.04:LTS | python-internetarchive | 1.9.9-1ubuntu0.1 | USN-7989-1 |
| Ubuntu:22.04:LTS | python-internetarchive | 1.9.9-1ubuntu0.1 | UBUNTU-CVE-2025-58438 |
| Ubuntu:25.10 | python-internetarchive | 5.4.0-1ubuntu0.1 | UBUNTU-CVE-2025-58438 |
| Ubuntu:25.10 | python-internetarchive | 5.4.0-1ubuntu0.1 | USN-7989-1 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jjjake | internetarchive | < 5.5.1 |
Weakness: CWE-22 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://github.com/jjjake/internetarchive/security/advisories/GHSA-wx3r-v6h7-frjp x_refsource_CONFIRM
- https://github.com/jjjake/internetarchive/commit/cba2d459e10a9489fb35caeba0b03e80f5f5d7c2 x_refsource_MISC
- https://github.com/jjjake/internetarchive/releases/tag/v5.5.1 x_refsource_MISC
- https://lists.debian.org/debian-lts-announce/2025/09/msg00030.html