Vulnerability · Published Sep 6, 2025 · Assigned by GitHub_M

CVE-2025-58437Coder's privilege escalation vulnerability could lead to a cross workspace compromise

High 8.1

In plain English

A high-severity security flaw in coder from coder. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.4%top 64.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Coder allows organizations to provision remote development environments via Terraform. In versions 2.22.0 through 2.24.3, 2.25.0 and 2.25.1, Coder can be compromised through insecure session handling in prebuilt workspaces. Coder automatically generates a session token for a user when a workspace is started. It is automatically exposed via coder_workspace_owner.session_token. Prebuilt workspaces are initially owned by a built-in prebuilds system user. When a prebuilt workspace is claimed, a new session token is generated for the user that claimed the workspace, but the previous session token for the prebuilds user was not expired. Any Coder workspace templates that persist this automatically generated session token are potentially impacted. This is fixed in versions 2.24.4 and 2.25.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/coder/coderno fix listedGO-2025-3938
Gogithub.com/coder/coder/v22.24.4GHSA-j6xf-jwrj-v5qp
Gogithub.com/coder/coder/v22.25.2GHSA-j6xf-jwrj-v5qp
Gogithub.com/coder/coder/v22.24.4, 2.25.2GO-2025-3938

Affected products (as reported)

VendorProductVersions
coder coder >= 2.22.0, < 2.24.4>= 2.25.0, < 2.25.2

Weakness: CWE-613, CWE-279, CWE-277 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

References